Planned Network Maintenance in Glasgow, York & Nottingham
Scheduled for 09 June, 2025 at 11:00 PM – 10 June, 2025 at 5:00 AM
Affects
CityFibre
Under maintenance from 11:00 PM to 5:00 AM
Completed
10 June, 2025 at 5:00 AMCompleted
10 June, 2025 at 5:00 AMMaintenance has completed successfully
In progress
09 June, 2025 at 11:00 PMIn progress
09 June, 2025 at 11:00 PMMaintenance is now in progress
Planned
09 June, 2025 at 11:00 PMPlanned
09 June, 2025 at 11:00 PMWe are planning for a scheduled maintenance during that time. Customers will experience a brief outage during the maintenance window