Plymouth, Edinburgh, Bishop's Stortford, Preston | Planned Maintenance
Scheduled for 01 April, 2025 at 11:01 PM – 02 April, 2025 at 5:00 AM
Affects
CityFibre
Under maintenance from 11:01 PM to 5:00 AM
- Completed 02 April, 2025 at 5:00 AM
- Completed - 02 April, 2025 at 5:00 AM- Maintenance has completed successfully 
 
- In progress 01 April, 2025 at 11:01 PM
- In progress - 01 April, 2025 at 11:01 PM- Maintenance is now in progress 
 
- Planned 01 April, 2025 at 11:01 PM
- Planned - 01 April, 2025 at 11:01 PM- Location: Plymouth, Edinburgh, Bishop's Stortford, Preston - Customers will experience a 30-minute outage during the maintenance window.