York | Emergency Maintenance
Scheduled for 14 February, 2025 at 12:01 AM – 4:01 AM
Affects
CityFibre
Under maintenance from 12:01 AM to 4:01 AM
Completed
14 February, 2025 at 4:01 AMCompleted
14 February, 2025 at 4:01 AMMaintenance has completed successfully
In progress
14 February, 2025 at 12:01 AMIn progress
14 February, 2025 at 12:01 AMMaintenance is now in progress
Planned
14 February, 2025 at 12:01 AMPlanned
14 February, 2025 at 12:01 AMLocation: York
CityFibre are conducting emergency maintenance on the network.
Approximately 30 Customers will experience a brief outage during the maintenance window